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Work Area 9 ICT SKILLS

3.15 USING SPREADSHEETS TO PRODUCE NON-
ROUTINE SHEETS

• LO78: Demonstrate ability to use a spreadsheet safely and securely 
to enter, edit and organise numerical and other data including more 
advanced formulas in order to meet the non-routine requirements 
of the office
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Module Details

Module Details

Module Details

Module Details

Module Details

Module Details

Work Area Code: 9

Work area title: ICT SKILLS

Unit Code: 3.15

Unit Title: USING SPREADSHEETS TO PRODUCE NON-ROUTINE SHEETS

Learning Outcomes Nos: LO78

Learning Outcomes titles: • LO78: Demonstrate ability to use a spreadsheet safely and securely to enter, 
edit and organize numerical and other data including more advanced 
formulas in order to meet the non-routine requirements of the office.

Recommended Duration: 4 hours

Trainer:
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Freeze rows function

• To freeze rows:

– You may want to see certain rows or columns all the 
time in your worksheet, especially header cells. 

– By freezing rows or columns in place, you'll be able 
to scroll through your content while continuing to 
view the frozen cells.

1. Select the row below the row(s) you want 
to freeze
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Freeze rows function

2. Click the View tab on the Ribbon.

3. Select the Freeze Panes command, then choose Freeze 

Panes from the drop-down menu.
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Freeze rows function

4. The rows will be frozen in 

place, as indicated by 

the gray line. You can scroll 

down the worksheet while 

continuing to view the frozen 

rows at the top. In our 

example, we've scrolled 

down to row 28.
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Freeze columns function

1. Select the column to the 

right of the column(s) you 

want to freeze. In our 

example, we want to 

freeze column A, so we'll 

select column B.
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Freeze columns function

2. Click the View tab on the Ribbon.

3. Select the Freeze Panes command, then 

choose Freeze Panes from the drop-down 

menu.
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Freeze columns function

4. The column will be frozen in place, as indicated by 

the gray line. You can scroll across the worksheet while 

continuing to view the frozen column on the left. In our 

example, we've scrolled across to column E.
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Freeze columns function

TIP: To unfreeze rows or 

columns, click the Freeze 

Panes command, then 

select Unfreeze Panes from the 

drop-down menu.
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IF function

• The IF function allows you to make logical 
comparisons between a value and what you expect. 

• In its simplest form, the IF function says:

– IF(Something is True, then do something, otherwise do 
something else)

• So an IF statement can have two results. The first 
result is if your comparison is True, the second if your 
comparison is False.
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IF function, examples

=IF(C2=”Yes”,1,2)

In the example, cell D2 says: IF(C2 = Yes, then 

return a 1, otherwise return a 2)
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IF function, examples

=IF(C2=1,”Yes”,”No”)

In this example, the formula in cell D2 says: IF(C2 = 

1, then return Yes, otherwise return No)
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Conditional formatting

• Conditional formatting applies one or more rules to 
any cells you want. 

• Access it in the Home tab
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Conditional formatting

• To create a conditional formatting 
rule:

• Select the cells you want to add 
formatting to.

• Select Highlight Cells 
Rules or Top/Bottom Rules. We'll 
choose Highlight Cells Rules for this 
example. A menu will appear with 
several rules.

• Select the desired rule (Greater 
Than, for example).
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Conditional formatting

• From the dialog box, enter a value in 
the space provided

• In this example, we want to format 
cells that are greater than 50, so 
we'll enter 50 as our value. 

• Select a formatting style from the 
drop-down menu.

• Conditional formatting offers many 
more options and functions. Go 
ahead and explore!
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Removing conditional formatting

• Select the cells that have conditional 
formatting.

• In the Home tab, click 
the Conditional 
Formatting command. A drop-down 
menu will appear.

• Select Clear Rules.

• A menu will appear. You can choose 
to clear rules from the Selected 
Cells, Entire Sheet, This Table, or This 
PivotTable.
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vlookup

• VLOOKUP lets you search for specific information in your spreadsheet. 

• There are four pieces of information that you will need in order to build 
the VLOOKUP syntax:

– The value you want to look up, also called the lookup value.

– The range where the lookup value is located. Remember that the lookup 
value should always be in the first column in the range for VLOOKUP to 
work correctly.

– The column number in the range that contains the return value. For 
example, if you specify B2: D11 as the range, you should count B as the 
first column, C as the second, and so on.

• The syntax for the VLOOKUP function in Microsoft Excel is:

• VLOOKUP( value, table, index_number, [approximate_match] )
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Creating a pivot table

• Click a cell in the source data or table range.

• Go to Insert > Tables > PivotTable.

• Excel will display the Create PivotTable dialog with your range or table 
name selected.

• In the Choose where you want the PivotTable report to be 
placed section, select New Worksheet, or Existing Worksheet. 
For Existing Worksheet, you'll need to select both the worksheet and 
the cell where you want the PivotTable placed.

• If you want to include multiple tables or data sources in your 
PivotTable, click the Add this data to the Data Model check box.

• Click OK, and Excel will create a blank PivotTable, and display 
the PivotTable Fields list.
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Working with a pivot table

• In the Field Name area at the top, select the 
check box for any field you want to add to your 
PivotTable. 

• By default, non-numeric fields are added to 
the Row area, date and time fields are added 
to the Column area, and numeric fields are 
added to the Values area. 

• You can also manually drag-and-drop any 
available item into any of the PivotTable fields, 
or if you no longer want an item in your 
PivotTable, simply drag it out of the Fields list 
or uncheck it.
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Working with a pivot table

• Summarize Values By

• By default, PivotTable fields that are 
placed in the Values area will be 
displayed as a SUM. 

• If Excel interprets your data as text, it 
will be displayed as a COUNT. 

• This is why it's so important to make 
sure you don't mix data types for value 
fields.

• You can change the default calculation 
by first clicking on the arrow to the 
right of the field name, then select 
the Value Field Settings option.
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Working with a pivot table

• Next, change the calculation in 
the Summarize Values By section. Note 
that when you change the calculation 
method, Excel will automatically 
append it in the Custom Name section, 
like "Sum of FieldName", but you can 
change it. 

• If you click the Number Format button, 
you can change the number format for 
the entire field.
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Essential advanced formulas

1. SUM

• Formula: =SUM(5, 5) or =SUM(A1, 
B1) or =SUM(A1:B5)

• The SUM formula allows you to 
add 2 or more numbers together. 
You can use cell references as well 
in this formula.
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Essential advanced formulas

2. COUNT

• Formula: =COUNT(A1:A10)

• The count formula counts the number of cells in a 
range that have numbers in them.

• This formula only works with numbers. It only 
counts the cells where there are numbers.
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Essential advanced formulas

3. COUNTA

• Formula: =COUNTA(A1:A10)

• Counts the number of non-empty cells in a range. It 
will count cells that have numbers and/or any other 
characters in them.

• The COUNTA Formula works with all data types.

• It counts the number of non-empty cells no matter 
the data type.
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Essential advanced formulas

• 4. LEN

• Formula: =LEN(A1)

• The LEN formula counts the number of characters 
in a cell, incl. spaces

5. TRIM

• Formula: =TRIM(A1)

• Deletes spaces in a cell, except for single spaces 
between words. 
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Essential advanced formulas

6. RIGHT, LEFT, MID

• Formulas: = RIGHT(text, number of characters), =LEFT(text, number 
of characters), =MID(text, start number, number of characters).

• These formulas return the specified number of characters from a 
text string.

• RIGHT gives you the number of characters from the right of the text 
string

• LEFT gives you the number of characters from the left

• MID gives you the specified number of characters from the middle 
of the word. 



This project has been funded with support from the 

European Union. This project reflects the views only of 

the author, and the Commission cannot be held 

responsible for any use which may be made of the 

information contained therein

.

Co-funded by the 

Erasmus+ Programme

of the European Union

Essential advanced formulas

7. SUMIF, COUNTIF, AVERAGEIF

• Formulas: =SUMIF(range, criteria, 
sum_range), =COUNTIF(range, criteria), 
=AVERAGEIF(range, criteria, average_range)

• These formulas all do their respective 
functions (SUM, COUNT, AVERAGE) IF the 
criteria are met. 

• There are also the formulas: SUMIFS, 
COUNTIFS, AVERAGEIFS where they will do 
their respective functions based on multiple 
criteria you give the formula.
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Essential advanced formulas

8. CONCATENATE

• Combining data in 2 (or more) different cells 
into one cell. 

• This can be done with the Concatenate excel 
formula or it can be done by simply putting 
the & symbol in between the two cells. 

• If I have “EUPA” in cell A1 and “NEXT” in cell 
B1 I could put this formula: =A1&” “&B1 and it 
would give me “EUPA NEXT”. 
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Essential advanced formulas

More Excel Formulas

• Time formulas (NOW, TODAY, 
MONTH, YEAR, DAY, etc.)

• Other formulas like AND and OR
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Inserting charts in Excel

• To insert a chart:

• Select the cells you want to 
chart, including the column 
titles and row labels. These 
cells will be the source data for 
the chart. 

• In our example, we have 
selected cells A1:F24.
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Inserting charts in Excel

• From the Insert tab, click the 
desired Chart command. In our 
example, we'll select Column.

• Choose the 
preferred chart type from the 
drop-down menu
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Inserting charts in Excel

• The selected chart will be 
inserted in the worksheet.

• Excel allows you to 
add chart elements

• To add a chart element, 
click the Add Chart 
Element command on 
the Design tab, then 
choose from the drop-
down menu.
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Inserting charts in Excel

• The selected chart will be 
inserted in the worksheet.

• Excel allows you to 
add chart elements

• To add a chart element, 
click the Add Chart 
Element command on 
the Design tab, then 
choose from the drop-
down menu.
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Spelling and grammar in Excel

• From the Review tab, 
click Spelling.

• The Spelling dialog box 
will appear. For each 
spelling error in your 
worksheet, Spell Check 
will try to offer 
suggestions for the 
correct spelling

• A dialog box will appear 
after reviewing all 
spelling errors. Click OK 
to close Spell Check.
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Activities

• Which functions of excel are 
necessary for creating or processing 
non routine documents?

• How can we check spelling and 
grammar of a spreadsheet?

• How can we add a chart?
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• Excel spreadsheets organize information

• Formulas and Functions
– Freeze panes

– If functions

– Conditional formatting

– Vlookup

– Pivot tables

– Other formulas

– Charts

– Spelling and grammar
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Create a spreadsheet

EUPA_LO78_M_01
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